Update to issue where add further tenants on edit and using multiple guarantors Tuesday 26th January 2021 14:28:00


Update: This is now fixed. The issue where adding further tenants during an edit and are also using multiple guarantors has been fixed on our testing site and after further testing will be deployed to the live site. The issue only affects editing an already created agreement. Creating a new agreement with the correct number of tenants has no issue.