Guild of Residential Landlords
Dashboard

All systems are operational.

Fixed

Fixed

3 years ago —

This issue appears to be now fixed. Please try any links in emails again and they should work. We apologise for the troubles.

Investigating

3 years ago —

As an update, Signable have escalated the issue and are still working on it. If you get the problem where a link in the email from signable doesn't work, please forward that email to info@landlordsguild.com. We will send the email to their support team. The more data they have the easier it is to fix.

3 years ago —

We are aware of an issue where Signable emails ask a party to sign or download a completed agreement, and a blank page appears on clicking the link. We are in contact with Signable about the issue and trying to find a fix.

Incident UUID 748a6ad7-417c-4fc9-8e29-03f51da65dbf