Guild of Residential Landlords
Dashboard

All systems are operational.

1 year ago —
Fixed

Fixed

1 year ago —

The websites are back up, including Tenancy Builder.

We sincerely apologise for the trouble. We have had to restore it from a recent backup. Please check that any recently created data is present.

Fixed

1 year ago —

We apologise for the continued downtime of the websites. The routine security updates are taking much longer than we expected.

We’re working hard to restore regular service.

1 year ago —

We are performing routine maintenance on our website servers today. Some websites may become unresponsive for periods. We apologise for any inconvenience.

Incident UUID 9f286fb0-98d9-4e69-b3e3-24ea25a402f1